Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.9dCi No Turbo Boost/Limp Mode*FIXED*

View Single Post
post #43 of (permalink) Old 13th December 2014
Junior Member
Join Date: Nov 2010
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 1 Time in 1 Post
Re: Renault Laguna 2 - 1.9dCi No Turbo Boost/Limp Mode*FIXED*

I think i have sorted my "limp mode" problem for now. I am sorry if this seems long winded but if you have had the problems i and several other owners have i think it will be worth 5 minutes to read.
I took the car to a very friendly local garage where the boss said he would plug her in and find out all the fault codes for me. He said he did not the have facilities to fix all problems that may show up but at least i would have some info. Amongst the extensive list of codes that appeared, i noticed nearly all the descriptions mentioned "incomplete reading due to battery low" or words to this effect. The battery was the original - 8 years old and had given me no problems in 4 years. The battery was checked and replaced, it had given good service but was time to go. I had also read up on DPF and how they are supposed to self clean. I will add a link later but it means the car needs ideal conditions to complete this operation, if it fails it can put the car into limp mode.
Basically the DPF needs heating up to roughly 600'C for 20 plus minimum to burn off the soot that has accumulated in the filter. It waits until the car is warmed up and cruising at a steady speed before adding extra fuel into the system to increase the temperature which it then needs to sustain for the 20 minutes. If the outside air temp is too low, or you change speed allowing the DPF to cool during the process, the system logs it as a failed attempt and you only get so many attempts. I travel 45 miles each way to London every weekend along the A1(M), and struggled to keep a steady 70mph for 5 minutes let alone 20 minutes.
I read that you can force a burn off by getting the car warmed up then sitting at 70mph in a lower gear to keep revs up hence keeping temperature up in the DPF, for 20 minutes or more! 4th gear was suggested but i did mine in 5th (6 speed box), not a very pleasant job as i try to look after my engine and economy. It also meant going out in the early hours onto a quiet A14 to achieve.
It worked !! I have not gone into limp mode since, the engine seems a little perkier and i have just completed a 1000 mile round trip to Germany without a hiccup. We did it cruising at mostly 75mph and 50mpg with 4 adults on board and a very full boot.
I am still getting yellow warnings coming up but not so often, i intend to get them cleared soon so i can get a clean sheet. I believe some of these warnings appear because of a false reading which could be due to a knackered battery, so i would recommend checking it before going any further.
Again, sorry for the epic write up but i thought it worth sharing, good luck.
Currently in mbe's garage:
2006 Laguna 11 1.9Dci
mbe is offline  
For the best viewing experience please update your browser to Google Chrome