Renault Forums :: Independent Renault forum - View Single Post - Laguna II Various Problems!!!!!

View Single Post
post #1 of (permalink) Old 27th June 2007 Thread Starter
TheDamo's Avatar
Join Date: Jan 2007
Posts: 32
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 1 Time in 1 Post
Angry Laguna II Various Problems!!!!!

I hope some one can shed a little light on my problems!!

To cut a long story short Following the heavy rain(Driving thru standing water on the passenger side the following has happened.

1-tyre pressure check not functioning the "lady" keeps telling me.The LCD Diagram of the car on the dash next to the clock has no wheels on it and the display on the instument panel is orange again no wheels and says sensor fault.

2- There is a snaped cable on the underside of the car running alaong side the brake pipes.The cable contains a RED BLACK and PINK wire.
Any ideas what this is?
Is this the cause of the above?

3-the Radio and Clock display have stoped working.The radio made a loud crackle(much to my sons amusement)and the display flashed for a minute the went dead.

4-the drivers and passenger windows will only go up an inch at a time.

No of these problems were present before the bad weather.And only started about 8 hours after the puddle incident.

any help would be welcome.

Currently in TheDamo's garage:
Laguna II 2.0dci Initale Touer and Traffic 110dci
TheDamo is offline  
  5 Lastest Threads by TheDamo
Thread Forum Last Poster Replies Views Last Post
Laguna II Phase II-Heated rear window Relay... Electronics mord 5 6363 28th November 2010 11:04 AM
Heated Seats,Mirrors+Rear window de mister not... Electronics AnotherLoser 8 3598 23rd October 2010 05:42 PM
Renault Trafic-Sat Nav GPS Arial Location Electronics willsp2009 1 5796 23rd October 2010 01:23 PM
Air Con Re-Gas!!! Engines madnoel10 10 2931 5th July 2007 07:59 PM
Wanted-TYRE PRESSURE CONTROL UNIT Electronics quiny-g 4 1094 29th June 2007 07:53 PM
For the best viewing experience please update your browser to Google Chrome