Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - 2.0 IDE engine problems !

View Single Post
post #32 of (permalink) Old 27th June 2007
Junior Member
XTRO's Avatar
Join Date: Aug 2006
Posts: 13
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Problem Solved

Well I was getting increasingly nervous about Renault stripping my Engine so I did some problem solving of my own as the power loss was getting worse and worse and I couldn't believe it was the valves.

So I checked the exhaust and its hardly putting out any pressure. My conclusion the cat is damaged and blocking the pipe. I took it to the local garage for a second opinion and the Guy agreed. So I cut the pipe today and had a look.
The cat was totally blocked there was some wire gauze in there that I think has come from the manifold joint or something (pics attached and the ceramic had broken. Basically you could hardly blow through it.

I fitted a new cat £180 eventually from europarts after drawing a blank with several motor factors. The car is like brand new now running absolutely perfect, better than when I first got it 10 months ago so its been a long term problem getting slowly worse.

IM ABSOLUTLEY FURIOUS WITH RENAULT ! How come they can spend 6 hours with my car on a diagnostic and not see a blocked pipe!!! You don't need to plug into the engine management just put your hand over the tailpipe and get someone to rev it, bloody common sense. They were going to strip my head down!! (Probably would never be the same again), and then would have said yeah you know we said it was the head, well the poor running has knackered the cat. So you need this too. So £2000 later I might have had a working car. I've already spent £200 getting the cam sensor replaced and that made no difference.

Tell you what I think the actual problem was someone has either repaired the flexible pipe at the manifold and some bits have broken off and been churning round in there for a few years, causing poor engine performance which in turn has exasserbated the problem. Have a look at the pics, anyone know what the metal gauze thing is I fished out ?? form the manifold end of the cat?

The car is perfect now, free revving nice idle and super quick the fuel economy has also jumped up 10mpg.

Attached Thumbnails
Click image for larger version

Name:	gauze2.jpg
Views:	125
Size:	3.2 KB
ID:	3508   Click image for larger version

Name:	gauze.jpg
Views:	125
Size:	3.5 KB
ID:	3509   Click image for larger version

Name:	dust.jpg
Views:	104
Size:	2.1 KB
ID:	3510   Click image for larger version

Name:	break2.jpg
Views:	91
Size:	2.5 KB
ID:	3511   Click image for larger version

Name:	Flex.jpg
Views:	97
Size:	3.5 KB
ID:	3512  
Currently in XTRO's garage:
Laguna 2.0 ide & Megane 2.0 16v Coupe

Last edited by XTRO; 27th June 2007 at 08:37 PM.
XTRO is offline  
For the best viewing experience please update your browser to Google Chrome