Renault Forums :: Independent Renault forum - View Single Post - Scenic electronic handbrake failed after pad change

View Single Post
post #9 of (permalink) Old 20th December 2014
Honorary Yorkshireman just in Derbyshire
Nottnoc's Avatar
Join Date: Dec 2008
Posts: 6,539
Nominated 19 Times in 15 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 1,572
Thanked 1,689 Times in 1,292 Posts
Re: Scenic electronic handbrake failed after pad change

Glad you're progressing. Never seen one myself. Don't understand why you say there is only one cable......yet. Sure my Scenic (not grand) has two.
How does one cable operate two calipers? Is there a "splitter box"?

Anyway, once you get the EPB box off, disconnect the motor (A MUST) from the PCB. Then apply a 12v battery across the motor, perhaps just "flashing" to see if it moves, if it doesn't, reverse the polarity & try again. If no sparks then the motor is duff. If sparks & no movement then it's jammed. It looks like there's a gearbox under the white bit, opening that may prove fruitful. Wish I could be there to help & learn.
BTW a thread I read recently suggested that EPB's were not coded & that they got one from a scrappy which worked immediately once fitted. As I suggested earlier, if that's not the case then you could unplug your PCB & fit to the scrappy mech.

Regards Tim,
You are only young once, but you can be immature forever
Give a n00b the answer he will be learn for a day; show him the search button, he will learn for life.
Currently in Nottnoc's garage:
2008 Scenic Mk2 Dynamique 1.6 K4M 782. 1998 BMW K1100LTSE, 1994 MotoGuzzi Caifornia 3 LAPD, 1972 Norton Commando, 2010 Trafic SL29 M9R782 115, Lots of tools, Camping Gear & Booze
Nottnoc is online now  
For the best viewing experience please update your browser to Google Chrome