Renault Forums :: Independent Renault forum - View Single Post - Renault Clio II - Engines - Non starter due to poor earth - Solved

View Single Post
post #1 of (permalink) Old 30th June 2007 Thread Starter
Join Date: Jun 2007
Posts: 34
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy Renault Clio II - Engines - Non starter due to poor earth - Solved

Hi All,

Got a 1998 Clio II, 1.2. When ignition turned on the dashboard lights come on as normal and go off as usual. However when I try to start it -nothing (apart from the sound of the fuel pump priming).

Thought it was the starter, so replaced it. Still no joy. Tested it with jump cables of my Safrane's battery and off it went, which made me think there was a problem with the earth lead. So used a jump lead to earth the engine block, and the engine started. Problem is that when I apply throttle the RPM increases and stays there and from the smell of the exhaust its running rich!!

Anyone out there technically minded who can advise me. I'm thinking its probably an expensive ECU problem, but would like to think it might be something simpler.

Would appreciate any thoughts, help or advice. If its an ECU then I think it will be the great scrap yard in the sky for this one.
Currently in boeingpete's garage:
Renault Safrane
boeingpete is offline  
  5 Lastest Threads by boeingpete
Thread Forum Last Poster Replies Views Last Post
Fuse rating for Renault Clio II Electronics ottoman 4 2678 10th April 2008 08:17 PM
Megane Coupe - Camshaft Position Sensor Testing Engines madnoel10 6 9034 16th February 2008 02:50 PM
Renault Safrane - Reset Service Indicator*FIXED* Other models Lagdti 10 17726 1st December 2007 04:32 AM
Renault Clio II - Engines - Non starter due to... Clio madnoel10 27 16664 30th June 2007 09:01 PM
For the best viewing experience please update your browser to Google Chrome