Renault Forums :: Independent Renault forum - View Single Post - megane problems

Thread: megane problems
View Single Post
post #1 of (permalink) Old 2nd July 2007 Thread Starter
Junior Member
Join Date: May 2007
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
megane problems


I bought my 03 megane in April from a non-dealer garage. This evening I went out to find my lights flashing and aloud tapping noise coming form the engine just to the right of the battery. The dash says there is an immobiliser fault. My brother is an electrician and had a look at it and say the noise is coming from a relay switch. He examined the fusebox in the engine and they were very damp.

Eventhough it looks so well and I love driving it I am really fed up with this car. This is the 3rd time i will have to return it to the garage. 1st time water in the fusebox ran the battery down. 2nd time the wiper motor burnt out. I have a 6 month warranty on the car and am looking for advice on how is the best way to approach getting my money back. I honestly have lost all confidence in the car.

Any advice will be greatly appreciated.
jpjc05 is offline  
  5 Lastest Threads by jpjc05
Thread Forum Last Poster Replies Views Last Post
megane problems Cars & motoring chris m 5 1175 2nd July 2007 10:03 PM
Hello! - Megane novice driver whose wipers have... Welcome to RenaultForums jpjc05 2 1208 9th May 2007 09:00 PM
For the best viewing experience please update your browser to Google Chrome