Renault Forums :: Independent Renault forum - View Single Post - Clio MK1 drive shafts

View Single Post
post #3 of (permalink) Old 8th January 2015 Thread Starter
John R
Junior Member
Join Date: May 2012
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Clio MK1 drive shafts

Thanks for your input - I finally solved the problem, it seemed that the tri lobed universal joint had come out of its outer housing, it stretched the rubber bellows but didn't break any clips or circlips - it didn't seem to be the spline -anyway we got a luggage strap around the hub back to a body member and racketed it up wiggled the thing and pop it suddenly went back in, quickly got the lower ball joint bolts on and problem solved- I don't how to word this but it might be useful to post something up about trying to keep the suspension leg back if your trying to change the lower ball joint maybe with a small strap - If the person doing this is inexperienced its easy for this to happen and when it does your quite stuck - I thought I'd broken something and would have to replace the drive shaft. so all well -except for discovering a small piece of broken suspension spring under the car after we'd bolted everything back together - that repair will have to wait for another day -I'm told its not too serious as long as I don't brake hard or thrash it - so I've driven it but very gingerly. Again thanks for your help
Currently in John R's garage:
clio 1, Citroen BX 1.4, CX break
John R is offline  
For the best viewing experience please update your browser to Google Chrome