Strange knocking - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11th September 2006 Thread Starter
Junior Member
Join Date: Mar 2006
Posts: 15
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Strange knocking

Hi, I have a 1999 Renault Scenic 19TD.
When i drive the car over bumps which is enevatible i can hear a metal like knocking coming from around the front wheel.
There is a steel bar approx. 1.5 in. thick. i think its the roll bar. when i bang it with my hand it seems to make the noise im hearing.
Please can anyone shed some light on this for me. Thanks.
Currently in Davey K's garage:
Renault Scenic 19 dti
Davey K is offline  
  5 Lastest Threads by Davey K
Thread Forum Last Poster Replies Views Last Post
For sale ?? General Chat Nick 1 1258 8th December 2009 11:34 AM
No Power Cars & motoring Davey K 3 1215 10th November 2006 10:35 PM
Strange knocking Cars & motoring Lagdti 2 1188 11th September 2006 09:54 PM
Petrol in Diesel car Cars & motoring RIKER1 2 1231 23rd April 2006 12:41 PM
Air bags Cars & motoring Lagdti 3 1122 21st April 2006 08:19 PM
Sponsored Links
post #2 of 3 (permalink) Old 14th September 2006
Platinum member
bonedavid's Avatar
Join Date: Jul 2005
Posts: 1,929
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 11 Times in 4 Posts
bump (no pun intended)
Currently in bonedavid's garage:
women wild
bonedavid is offline  
post #3 of 3 (permalink) Old 14th September 2006
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
It sounds like you have an anti roll bar drop link or bush gone.

There is either an arm that comes from the suspension leg onto the anti roll bar or the roll bar bolts onto the wishbone directly.If you have an arm,then I suspect that one of the joints on the end has gone,or,if you have the bar bolted to the wishbone I suspect that the rubber bush between the two has worn.

If neither of these are obviously at fault,then it could be the actual mounting bushes on the roll bar where it bolts to the subframe.

Edit;If you can take a picture of the front suspension lay out,I'll show you where the components are.(That might be easier!)

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  

knocking , strange

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome