Recent Grand Scenic purchase - faults to look for?? - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 6 (permalink) Old 24th September 2013 Thread Starter
Junior Member
Join Date: Aug 2009
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Re: Recent Grand Scenic purchase - faults to look for??

Further to my previous question, the last few weeks have seen two occurances:

1) wife driving and the front seatbelt warning sounded, and didn't stop. obviously the belt was clipped
2) couple of days ago the rear belt warning on the display. Again, the only belt in use was clipped properly.

Stopping the engine seemed to reset and fix. This may be tricky to return to the garage while its intermittent - they tend to want to see the thing happen .

Is there a way of checking if my vehicle has the latest software installed??? This seems more likely the cause rather than a mechanical fault with both belts. I am concerned that this could be the start of a series of 'electrical issues'!
hmmmmrara is offline  
Sponsored Links

faults , grand , purchase , recent , scenic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome