Scenic Dci 1.9 Loss Of Power, Help - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 6th March 2007 Thread Starter
Junior Member
Join Date: Mar 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question Scenic Dci 1.9 Loss Of Power, Help

Hi all. Can anyone help with this one? My scenic 1.9 dci dynamiquehas been having a problem picking up power. When it gets to about 2000 revs it seems to jump into action but when going up hills it seems to lack power. I have taken it to 2 garages now and the renault garage thought it was egr valve. So I paid them to clean ita nd put it back but they said that was fine and do not know what it is. They also checked the turbo pipes and turbo spins freely.Without letting them have it all day and pay a fortune for them to discover the problem does anyone have any ideas? By the way the light that looks like a coil ( that heats the bulbs I believe( sorry im a woman!) keeps coming on. Please help.Thanks Lisa.
Currently in lisam's garage:
lisam is offline  
  5 Lastest Threads by lisam
Thread Forum Last Poster Replies Views Last Post
Scenic Dci 1.9 Loss Of Power, Help Cars & motoring Lagdti 3 2308 6th March 2007 08:01 PM
Sponsored Links
post #2 of 4 (permalink) Old 6th March 2007
Junior Member
Join Date: Dec 2006
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
re - dci engine propblem

I have the same problem with my 2002 megane 1.9dci when I hit 70mph the orange coil / ecu light comes on and i lose power, when i drop to 60mph the light goes off and power returns.

I've been to the main dealer and they are are bunch of donuts, they know nothing!!!

If you have any joy please let me know

Many Thanks
Currently in happy snapper's garage:
Renaut Megane 1.9dci 2002
happy snapper is offline  
post #3 of 4 (permalink) Old 7th March 2007
Junior Member
Join Date: Dec 2006
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I had a similar problem on my laguna 1.9dci.

Took 4 goes at the garage (under parts warrenty, cost me 2 investigation and 4 hrs labour) and they eventually changed a "vacuum valve" they were no more specific than that and as they were not charging me due to the 3 other goes failing I left a happy man.

First try glowplug
second try glowplug heater wiring fault
third try glowplug heater controller

I tried to tell them it probably wasn't the plugs but they are the experts.

also the EGR was mentioned but the "vacuum valve " fixed it

All OK now 6 weeks on. Much nippier and better MPG.
Currently in nash's garage:
2004 renault laguna 1.9dCi initialle 120 sports tourer
nash is offline  
post #4 of 4 (permalink) Old 7th March 2007
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
I've had a simialr problem on a Vauxhall Vivaro van,which is really a re-badged Renault Traffic.It uses a variant of the 1.9dCi engine also.

The problem was no power,no turbo boost and the management light was on.I traced the problem to the turbo boost vaccuum unit,and when I phoned up Renault to get another one they said that they kept 8 of them in stock and it was a common problem!.Fitting the valve transformed the van and the management light immediately went out.

The unit has two small hoses running to it,one from the inlet manifold and one to the vaccum unit on the turbo which controls boost pressure.

To help diagnose the problem I brigded across the two pipes with a piece of brake pipe and road tested the van.It was immediately better,so trying that might help.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  

dci , loss , power , scenic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome