HELP ME ANYONE ! engine problem - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 6 (permalink) Old 27th September 2005
FrenchFanRTE's Avatar
Join Date: Aug 2005
Posts: 87
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 4 Times in 3 Posts
I think before you go down the route of head gaskets, I think you should get the ignition coils checked out in case of a misfire which is what it sounds like you have, the light that may have come is the emissions light due to the misfire, and the water level may of been just a coincidence...
Currently in FrenchFanRTE's garage:
2007 Clio III 1.2 TCE Dynamique
FrenchFanRTE is offline  
Sponsored Links

engine , problem

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome