has anyone fitted a 480 turob into a clio? - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 6 (permalink) Old 19th March 2007
Platinum member
Join Date: Jan 2006
Posts: 2,637
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 48
Thanked 372 Times in 284 Posts
I knew a bloke that dropped that unit into a Mk1 Lag. I've had a few people ask for contact details but he's not answered any emails I've sent him ..... & I think he's changed his mobile number I'll ask around and see if anyone can get a hold of him


I think I have CDO. It's like OCD, but with ALL THE LETTERS IN THE RIGHT ORDER
Currently in Gonescenile's garage:
A wee French toy & a 2010 Honda VFR 800
Gonescenile is offline  
Sponsored Links

480 , clio , fitted , turob

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome