Clio 197 2008 Vibrations through pedals - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 18th September 2013 Thread Starter
Junior Member
Join Date: Sep 2013
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Clio 197 2008 Vibrations through pedals

Hi there,

Recently bought a Clio 197 2008.

I've noticed vibrations in all 3 pedals mainly at 3500rpm (moving and static). The vibrations do not occur when the car is free wheeling, only when accelerator is applied. There are no other knocks or sounds, just a little more "noise"when I reach 3500rpm.

Car has just been serviced and MOT'd.

I've taken it to Renault Edinburgh, they have checked engine mounts, heat shield etc for anything loose and any failed parts and cannot find the fault.

Having to now take the car back until they have another 197 in the garage to compare it to.

Any ideas?
Currently in cameronsuth1000's garage:
Renaultsport Clio 197 2008 2.0L
cameronsuth1000 is offline  
  5 Lastest Threads by cameronsuth1000
Thread Forum Last Poster Replies Views Last Post
Clio 197 2008 Vibrations through pedals Cars & motoring cameronsuth1000 0 598 18th September 2013 03:32 PM

197 , clio , pedals , rpm , vibrations

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome