Problems with a mk2 megane 2003 1.5 dci - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 29th September 2013 Thread Starter
Junior Member
Join Date: Sep 2013
Posts: 20
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 0 Times in 0 Posts
Problems with a mk2 megane 2003 1.5 dci

Hi everyone,

I recently bought a Megane at an excellent price however I took a risk as the car only had a weeks MOT left. Ive purchased the car so its safe to say theres no going back. First thing I did was take it to a local garage for a check up and prep for MOT. I got them to change a few parts such as cv boot, rear disks and pads which they said required changing. Ive also purchased all the filters, timing belt kit and oil so when it was going to pass the MOT I would get it serviced. The cars done 99k miles to date.

The cars failed the MOT....sigh. A few things are easy fixes such as windscreen washer providing insufficent fluid, top strut mount with bearing and other bits and pieces. Two things I am concerned about however. One is that the airbag light is on and the garage have said to me they will try to get it fixed. Ive read the forums in detail here and it could be as simple as the wires being loose under the seats? Anyone got any other ideas and the cost involved.

The other issue which is my primary concern is that theres a potentiol problem with the steering. The car says check steering on display and Ive noticed that sometimes when braking I get some vibration through the steering wheel. What could this possibly be? warped disks? Surely the mechanics would have spotted a problem when I asked them to check the car?

The garage have referred my car onto a specialist garage who specialise in steering matters. They will hook it up to a diagnostics machine and take it from there. Should I be worried at this stage? What sort of problems could cause this?

One other issue is the other day when I attempted to start the car it wouldnt start, the card key appeared to not work. The spare dosent work at all and the one I have seems to cause problems. It didnt detect the card then after 20 minutes of trying it worked! Again..Ive had a look on here and it could be that the card key needs repaired. A few sellers on ebay have their service advertised for only 20. Could I send the old one (the one that dosent work to be repaired) or should I send the working one?

Better still Im in Glasgow, if anyone can recommend anyone for the card key problem I would be greatful.

Thanks guys.
Currently in obayda1991's garage:
2003 Reanult Megane mk2 1.5 dci
obayda1991 is offline  
  5 Lastest Threads by obayda1991
Thread Forum Last Poster Replies Views Last Post
steering issue (Megane 2003) Steering and Suspension ste2425 6 1428 6th September 2014 03:54 PM
Megane 2003 1.5dci electrical issues! Electronics Nottnoc 5 1135 22nd June 2014 05:44 PM
Bacbox for megane Exhausts scatz 1 760 8th January 2014 03:31 PM
Wishbone 16mm or 18mm? Steering and Suspension TTT 1 848 8th January 2014 03:27 PM
Am I looking at the right parts? Wheels & tyres obayda1991 0 557 8th January 2014 03:20 PM
Sponsored Links
post #2 of 2 (permalink) Old 7th October 2013
Junior Member
Join Date: Jul 2009
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Problems with a mk2 megane 2003 1.5 dci

For the keycard - I came accross this the other day - maybe it will help:
Currently in bencummins's garage:
2003 Renault Megane II 1.9dCi
bencummins is offline  

dci , megane , mk2 , problems

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome