Renault Megane - Various Problems - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 27th May 2007 Thread Starter
Junior Member
Join Date: Feb 2007
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Megane - Various Problems

Hello everyone. I popped up a while ago wanted to make my Clio road legal in Germany. Well I bought all the bits, and made an appointment with myself, a cup of coffee and a box of spanners to swap them all over. The week leading up to this weekend though, the car was parked outside work and was driven into my a 40tonne lorry. It wrote it off, as you can imagine.

As a replacement I have bought a 2003 Megane, 1.6 petrol 3 door Authentique. My father has the same car (slightly newer) in the lesser spotted saloon version.

Anyway, there are two problems. Both rate as annoying but not anything that prevents me driving or enjoying the car.

The first one is the drivers electric window. Sometimes this works fine, but sometimes the one touch simply doesn't work. The window will go down completely, but in 4 or 5 steps, where you have to press the button 4 or 5 times. It is reliable, but annoying. Any tips? I guess I need to pop the interior trim off, and have a look!

The second is the external temp guage. It lies. Sometimes it is fine, and will give a realistic temp. Others it will make it up (telling me it is -34 degrees, when outside it is about 29 degrees C). The sensor, on the underside of the mirror is loose, and you can wiggle it around a bit. I am hoping it is just a poor connection here (there is scratching on the mirror casing from the previous owner). This also isn't a fault that ruins the driving pleasure, but what it does do (or seems to) is upset the climate control when it is on automatic, as it will start pumping out the wrong temperature air!

Oh, one third thing. There is a click on the steering when you are moving towards maximum lock. Hmm....

Any help greatly received. Rich
Currently in richardtoddywoddy's garage:
2003 Renault Megane Authentic 1.6 3 door, LHD

Last edited by richardtoddywoddy; 28th May 2007 at 09:27 AM.
richardtoddywoddy is offline  
  5 Lastest Threads by richardtoddywoddy
Thread Forum Last Poster Replies Views Last Post
Megane II: Is it the battery? Engines richardtoddywoddy 2 961 10th December 2007 07:45 AM
Drivers Window & Door card Electronics scatz 3 8847 24th August 2007 04:12 PM
Megane leaking air con Cars & motoring ottoman 3 1310 16th July 2007 09:13 AM
Renault Megane - Various Problems Cars & motoring llama_boi626 3 1567 27th May 2007 09:48 AM
Clio bonnet catch plastic retrainer Clio ottoman 2 1642 2nd March 2007 04:40 PM
Sponsored Links
post #2 of 4 (permalink) Old 28th May 2007
Platinum member
Join Date: Aug 2005
Posts: 14,145
Nominated 2 Times in 3 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 68 Times in 26 Posts

Hopefully a Member will be able to advise you on your post shortly


ottoman is offline  
post #3 of 4 (permalink) Old 30th May 2007
Junior Member
Join Date: May 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
recently had prob with drivers window, switch didnt work well, think u might have same prob. The prob was with diry connectors both on wires and switch, cleaned them and works now well. Although my meg is from 1996. it could be the same prob with your switch.

The prob with the temp gauge is probably regarded to connector in the door, pull it off and try cleaning, u have nothin' to loose.

It's recommended not to move steering "towards maximum lock", that's all i know.

Hope it's all simple probz as i wrote
mika is offline  
post #4 of 4 (permalink) Old 22nd April 2012
Junior Member
Join Date: Jul 2010
Posts: 25
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 11
Thanked 0 Times in 0 Posts
Re: Renault Megane - Various Problems

hello, i have the same problme with the sensor and the click. i fixed my temp sensor by cleaning the contacts on the connector on the door and the click was worn suspension top mounts. about 80 to get it put right. wasnt so much a sefety risk, just an annoyance.

hope this helps
Currently in llama_boi626's garage:
2003 renault megane 1.9 dci 120
llama_boi626 is offline  

megane , problems , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome