Renault Laguna II Phase 1 - Interiors - Instrument Panel Failure - Page 8 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #36 of 41 (permalink) Old 4th February 2007
Junior Member
Join Date: Jan 2007
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Burnbank View Post
I have just found a link to the following UK company, who claim they can repair the faulty parts and guarantee it for 2 years.

Renault Laguna dashboard instrument cluster problems
Iwouldnt trust BBAreman to be honest. I sent one to them once before and it came back a week later unrepaired. I could never talk to the person in the workshop who was repairing the unit because he was always out, oor had poped over to the "other building". This has happened every time I have had dealings with BBA, and on occasions when I have phoned for tech advise it is quite clear that my knowledge and experience is far greater than theirs. A customer of mine (trade customer) sent an ECU to them for repair. When it came back and the car still didnt run they called me in. I not only traced it to an ECU fault but knew what the fault was. I phoned BBA and told the telephone operator what the fault was but he did not understand - again the technician was "at the other building". The garage sent the ECU back for repair and it was returned from a completely different company!! They dont have a workshop at all - they dont repair anything - they just send it to people who do have a workshop and can repair it!!

As I said in my last post in this thread if you can put up without the car - or without the dash in the car for a couple of weeks then post me the dash and I will attempt to repair it for nothing but the price of the carriage (whether I repair it or not) but I cannot make any garuntees I can repair it until I get a unit to try with.
Currently in delambo's garage:
my wife to despair!
delambo is offline  
Sponsored Links
post #37 of 41 (permalink) Old 5th February 2007
Junior Member
Join Date: Feb 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Rest assured, you have another entry to Watchdog on it's way from another disgruntled Laguna II owner.

I have been suffering with the failure of my instrument panel since the cold/wet weather kicked in and as everyone else has experienced, Renault have diagnosed it (at a cost of 60) of needing replacment (a further 400 + fitting). I have found a temporary solution to the matter however. When the panel has failed warm the engine for a good half hour then switch it off and disconnect the battery for a few seconds. When reconnected the panel works again - but only until another cold, frosty night occurs......then it's back to opening the bonnet.
Fingers crossed Watchdog can help us all out as with fitting this is likely to be a 1,000 fix!

Also on the window regulator front, I have the same issue with my drivers window completely non-functional now. It did work - albeit very slowly, but now has stopped all together. Is it easy enough to attempt a fix on the Driveway before forking out for a new regulator, and if so, what's the best approach?
Currently in areeves1980's garage:
Renault Laguna II 1.8 Dynamique
areeves1980 is offline  
post #38 of 41 (permalink) Old 26th April 2007
Junior Member
Thecarboss's Avatar
Join Date: Apr 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Delambo
I would be interested in a chat regarding the dash fault.
I am a car dealer and sell loads of these cars but this is the first one I have come across. (sold over 30 secondhand Diesels) I am in the process of replacing a used unit so I may have a spare unit for you to try.(
Currently in Thecarboss's garage:
Renault Laguna II 1.9dCi.
Thecarboss is offline  
post #39 of 41 (permalink) Old 26th April 2007
markandjan's Avatar
Join Date: Mar 2006
Posts: 49
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down Instruments

My Lag has the same problems..........450 at renault to repair!.............for the moment I have fitted a battery diconect switch(4.99) so when the pod fails its quick and easy to reset but it does mean I have to reset radio/clock/widows everytime.I will put up with this till the whole pod gives up the ghost!
Currently in markandjan's garage:
Laguna Sport Tourer
markandjan is offline  
post #40 of 41 (permalink) Old 15th May 2007
Diamond member
vicfisher's Avatar
Join Date: Apr 2007
Posts: 105
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Is it possible I have the same problem? I have a 2001 3.0 v6 sport tourer privilege.

There is no 'Insert Card' message on entering the car.

Once card is inserted, it appears to go through the checking procedure and states 'All OK'. The car starts and runs ok.

There has been an incidence of driving off with the door not properly shut but there was never any warning.

Although there has been no major faults like the ones described here, I'm just beginning to wonder if all is ok with this unit.

"I'm not easily distrac... ooh ooh look, shiny thing"
Currently in vicfisher's garage:
Citroen C4 Picasso VTR+ 1.6HDi EGS
vicfisher is offline  

failure , instrument , interiors , laguna , panel , phase , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome