TDC sensors - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 16 (permalink) Old 23rd November 2005
Posts: n/a
Bump - we've got members asking for updates on this one. If we can gather some information together I'll turn it into a proper article
Sponsored Links
post #7 of 16 (permalink) Old 23rd November 2005
Platinum member
scen1c's Avatar
Join Date: Jul 2005
Posts: 4,285
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 0
Thanked 68 Times in 6 Posts
I was going to post pics when I did the mother in laws TDC but I haven't done it yet! The service I did sorted her starting problems...
Currently in scen1c's garage:
Toys. Toys. More toys. A freezer.
scen1c is offline  
post #8 of 16 (permalink) Old 23rd November 2005
A former user
Posts: n/a
If I post a picture of my engine bay can someone point out where the bloody thing is just in case it ever fails ?
post #9 of 16 (permalink) Old 26th November 2005
Diamond member
DJC013's Avatar
Join Date: Oct 2005
Posts: 437
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 9 Times in 9 Posts
Thumbs up

My dad runs a 1989 Renault 21 2.0 injection in France, he had intermittant starting problems. Guess what, dodgy TDC sensor, about 15 and then it was sorted !
Currently in DJC013's garage:
2004 Scenic II 1.9 dCi Dynamique 6 Speed Black (VF1 JMRG) F9Q 812 NDO
DJC013 is offline  
post #10 of 16 (permalink) Old 22nd December 2005
Junior Member
Join Date: Oct 2005
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to MeganeRT16
I drive a 1.6 8v 1997 megane and i figured out that the problem with my car could be the TDC since the revs some time get stuck at like 1500 rpm but when i come to a stand still they fall back down again...

sometimes instead it also starts cutting out (stalling) as soon as i free it...
Does anyone think this is the case?? Pls help

MeganeRT16 is offline  

sensors , tdc

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

  LinkBacks (?)
LinkBack to this Thread:
Posted By For Type Date
Megane Problems - This thread Refback 2nd December 2007 01:28 PM
Megane Problems - This thread Refback 30th November 2007 09:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome