Clio 2 - Violent Juddering - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 24th December 2007 Thread Starter
Junior Member
Join Date: Dec 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Ooops, yep bonnett lever. Yeah, I removed the bulb thanks.

I think I'm just going to take it into a garage after xmas. It's just frightening when I have no idea what it's going to cost me. I mean, 200 for 2 sensor replacements? - where's it going to go next.......
nick3young is offline  
Sponsored Links
post #7 of 7 (permalink) Old 10th March 2008
Junior Member
Join Date: Mar 2006
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I have a similiar problem. My 2000 Megane judders in the morning, especially when temperature is cold. And after I replaced my thermostat housing after a leak, the problem disappeared. Hope this helps. Also the high speed (>140 km/h) steering wheel shaking disappears too! Strange
Currently in bloodaxe's garage:
Megane Classic I
bloodaxe is offline  

clio , juddering , violent

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome