Mégane ll 1.9dCi Problems - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 11th August 2005
Diamond member
Join Date: Jul 2005
Posts: 95
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I am convinced the 18K service intervals are the cause of turbo failure. Oil is the life blood of the engine and turbo .

My advice to any dCi owner is to change it at least every 10K or 12 months. Webcode, the RTE who often posts here, recommends 6K or 6 months. And use a good quality fully synthetic oil . Amsoil is well regarded.

Interestingly, the Euro4 dCi engines are back to 9K service intervals...

I'm a great fan of Renault and to be fair mine have been very good, a few minor issues apart. But at times I feel I am swimming against the tide. Renault ought to give me a free car, the number of people I've recommended the cars to over the years...
Xileno is offline  
Sponsored Links
post #7 of 8 (permalink) Old 11th August 2005
FrenchFanRTE's Avatar
Join Date: Aug 2005
Posts: 87
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 4 Times in 3 Posts
The only engines that have been reduced to 9K servicing are types fitted with a particulate filter in the exhaust, there are not many of them out there at the moment, but also these engines, especially the new Nissan/Renault diesel engine will require a different oil again to prolong the life of the particulate filter.
Currently in FrenchFanRTE's garage:
2007 Clio III 1.2 TCE Dynamique
FrenchFanRTE is offline  
post #8 of 8 (permalink) Old 11th August 2005 Thread Starter
Join Date: Aug 2005
Posts: 65
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Sans Prix
Indeed it would seem that the Euro lV engines are back to 9,000 miles and 100% synthetic. I was informed that this was the case with the 130 dCi Mgane anyway.
Currently in Sans Prix's garage:
2003 Mgane ll 1.9dCi
Sans Prix is offline  

19dci , mégane , problems

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome