engine just clicking - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 7th July 2006 Thread Starter
Junior Member
Join Date: Jul 2006
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to pupsi
FIXED IT and am very happy now as well.
stupid thing really, the power cable goes from the alternator to the starter motor and then to the battery and thats why it wasnt workin when i cut the original wire at both ends and replaced only the alternator wire not knowing that this is connected to the starter motor as well.
therefore ive jus connected sum power cable to the battery from the starter motor and everything now works fine.
thanks everyone for all your help
Currently in pupsi's garage:
1999 Clio 1.2 Grande
pupsi is offline  
Sponsored Links
post #12 of 12 (permalink) Old 7th July 2006
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
great news thanks for the update
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  

clicking , engine

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome