Renault Forums :: Independent Renault forum - View Single Post - List of little issues on Megane

View Single Post
post #1 of (permalink) Old 16th July 2007 Thread Starter
Junior Member
Join Date: Jun 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
List of little issues on Megane

Hello everybody

97, Renault Megane Diesel Turbo

i bought it a couple of months ago and there are just a couple of little things i wondered if anyone could give me assistance.

1. i am getting no power to my glow plugs. this means i cannot cold start it without connecting a crocodile clip to the positive side of the battery and holding the other end on the glow plugs. is there anything simple i can look for? fuses, for example?

2. the rear window wiper does not work. i have replaced the fuse (at least i think it was the correct one!) but it still does not work. is it an easy job to take the cover off the rear wiper motor to dubyadee forty it? if it's seized up, i don't want to try it and blow the fuse.

3. the wiper washers don't work. is this a fuse somewhere or could it be more tricky than that?

4. my fog lights don't work unless i'm indicating right.... sounds like an electrical issue but will it be possible for me to fix? as in, will it be a dealership job or bloke-at-home job?

now, people may ask why i bought a car with these things wrong but it was a damn good price and there were only these little things wrong...fixable but annoying!

any help would be appreciated on any of the matters
Currently in letmeoutofhere's garage:
1997 Renault Megane 1.9 Diesel Turbo
letmeoutofhere is offline  
  5 Lastest Threads by letmeoutofhere
Thread Forum Last Poster Replies Views Last Post
List of little issues on Megane Cars & motoring deano23285 4 889 16th July 2007 09:37 AM
Battery and Clifford alarm Engines letmeoutofhere 6 1485 24th June 2007 05:40 PM
For the best viewing experience please update your browser to Google Chrome