Renault Forums :: Independent Renault forum - View Single Post - Megane III Brakes Problem

View Single Post
post #1 of (permalink) Old 18th February 2015 Thread Starter
Junior Member
Join Date: Feb 2015
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Megane III Brakes Problem

Hello, I am writing about a brakes problem on my Megane 2011 model. It all started in December when i realized the brakes pedal is a bit soft and it doesnt stop as it should be. After a visit to a local garage they said my rear back wheel was blocked and the pads were a bit rusty so they tood them out and cleaned them. I was told there is air in the front left wheel and they bled the system oldfashion way. After a week it was the same so it was bled again, and the same no brakes after 2-4 days. I went to a Renault dealer and i explained what is wrong so they bled the system and it only lasted 3-5 days again. The symptoms are. pedal getting soft when u press the brake pedal and if u try to stop in emergency only front right wheel locks the left one looks like doesn't stop. I went back to Renault and they said its the master cylinder. They replaced the cylinder with a brand new one and bled the system. Again after a week the same story again. Also I noticed when i press the brakes pedal a noise like air coming out sound like from the servo and when u pump the pedal few times the pedal not only gets harder but the servo makes strange noises for a while and then stops. I went again to Renault garage and the said the will pressure bleed this time, so they did and the car was perfect for 7 days. on the 7th day i was driving and i had t stop hard in an emergency and the abs on the car was working in order to stop and immediately after that i felt like there is something wrong with the brakes again. 4 days later i have again air in the same left from wheel and no proper brakes. They told me in Renault its probably the servo but probably yes may be not it costed me a fortune so far and even more to replace servo if I decide to. Please anybody with similar problem or a clue what is doing all this, is it realy servo, is it some air still left to give me an advice.
Currently in vladograka's garage:
Megane III 1.5 dCi
vladograka is offline  
The Following User Says Thank You to vladograka For This Useful Post:
zuzutje (15th April 2016)
  5 Lastest Threads by vladograka
Thread Forum Last Poster Replies Views Last Post
Megane III Brakes Problem Brakes/Hubs macho29 22 4155 18th February 2015 06:22 PM
For the best viewing experience please update your browser to Google Chrome