Renault Forums :: Independent Renault forum - View Single Post - clio 1.2 exp. 2001 insurance claim problems ECU

View Single Post
post #2 of (permalink) Old 25th July 2007
Platinum member
TazzyK's Avatar
Join Date: Mar 2006
Posts: 1,076
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 30
Thanked 73 Times in 63 Posts
I'd go along with the theory of the ECU being damaged with booster cables etc. The site I visit for my Alfa always tell you to not jump start cars as a 'spike' is all it takes to damage the ECU .

Ask them if the car's battery went flat, and if so, how the car was started.

I'd also be adamant that since there were no other problems with the car apart from the damage to the wing etc, that they need to return the car to you with the damage repaired (because thats what it was there for) and otherwise in the same condition mechanically or otherwise as they got it.

I don't see why you should be paying for something that you weren't aware of in the first place. It just seems convenient that they've done something and you're having to pay to have it repaired.

In any case, IF the ECU was water damaged, then more than likely this would be due to the accident you had and therefore everthing affected should be covered under your insurance (is the ECU on the same side as the damage? If so and the leak is still there then thats poor workmanship).

I'd also be writing a stern letter to my insurers and tell them to sort it out if they want your continued custom (and also send a copy the insurance ombudsmen or something)
Currently in TazzyK's garage:
Renault Clio 1.4 16v Privilege (2004), Renault Megane 1.5 dCi 106 Expression (2005), Volkswagon Passat 2.0 TDi S (2006), Alfa Romeo 159 2.4 JTDm QTronic Lusso (2008)
TazzyK is offline  
For the best viewing experience please update your browser to Google Chrome