Renault Forums :: Independent Renault forum - View Single Post - MOT - 3 issues with brakes

View Single Post
post #3 of (permalink) Old 2nd March 2015
Diamond member
ste2425's Avatar
Join Date: Oct 2012
Posts: 349
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 30
Thanked 40 Times in 39 Posts
Re: MOT - 3 issues with brakes

Just an FYI may not help but my Fiat failed MOT on the last two. It also had drums on the rear.

I cleaned them up, replaced shoes and springs and also got new handbrake cables. However it still failed on the handbrake not functioning correctly. Turned out to be the back plate which had rusted and split, so when the handbrake was applied the backplate would flex instead of the shoes being expanded. Thanks to ridiculous amounts of Hammerite applied by a previous owner i couldn't see the split and didn't notice the small amounts of flex. So yea, just thought it might be worth mentioning.

The Lord said unto Sven, "Though shalt not put thine 2-stroke V8 outboard into the hallowed Volvo, for it would be an abomination in the eyes of the Lord." But Sven disobeyed our Lord God and installed it anyway. The Lord was displeased but Sven had faith in his creation. Upon the Amazon's first start, the sounds of eight powerful trumpets rang through the heavens and to the ears of our Lord. The Lord looked upon Sven among the blue smoke and smiled. For in his eyes, he knew it was righteous.
Currently in ste2425's garage:
2003 Ford Ka 1.3 : 2003 Renault Megane 1.4 16v (RIP) : 1997 Fiat Cinquecento S (RIP) : 2000 Vauxhall Corsa (RIP) : 1997 Citroen Xsara 1.4 (RIP)
ste2425 is offline  
The Following User Says Thank You to ste2425 For This Useful Post:
Phil48 (2nd March 2015)
For the best viewing experience please update your browser to Google Chrome