Renault Forums :: Independent Renault forum - View Single Post - Laguna - Windscreen Washer & Radio Cover "Problems"

View Single Post
post #2 of (permalink) Old 29th July 2007
chris m
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
Originally Posted by BaileysOriginal View Post
Dear All,

I joined this forum earlier this week and have found that there is a great deal of interersting stuff here. I've already received some very useful advice.

I have a few new questions and I would be most grateful if any of you could help to shed any light on them. I own a Renault Laguna (2001 model).

1) The rear windscreen washer does not work. The wiper moves but no washer fluid comes out. What could be the cause? The front one works fine.
Could be a blocked pipe or nozzle, put a pin in the nozzle to clear and try, if no luck disconnect the pipe and blow through it, if still not working it may be the pump.
2) The radio cover does not work like it used to. Before it used to open when I pressed it, but now there seems to be something wrong with the mechanism as I have to pull it open. Then I have some trouble getting it to stay down when closing it. Any ideas, please.
Not too sure on this but I would suspect it has a spring in it that may have come loose
3) The electric window controls on the driver's side get very hot. What could be causing this?
Sounds like a connection in the switch may be shorting, pull the switch out and check the wires and terminals. Have a look a this post here for related info.
Many thanks for taking the time to read this.
Good luck, keep us updated
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
For the best viewing experience please update your browser to Google Chrome