Renault Forums :: Independent Renault forum - View Single Post - Renault Megane - Hub Nut Question

View Single Post
post #1 of (permalink) Old 15th August 2007 Thread Starter
dweeb monkey
Junior Member
dweeb monkey's Avatar
Join Date: Aug 2007
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Renault Megane - Hub Nut Question

hi folks,my wifes megane was in the garage getting the wheel bearings ,track rod ends and ball joints done and being retested,thankfully it passed .
after bringing it home my wife noticed a squeaking noise coming from the osf wheel as the car was driving along ,i had a look but couldnt see anything untoward ,but what i did notice was that where the new wheel bearing had been replaced the shaft that holds the hub nut had been cut off at the end and now is flush with the new nut,can anyone tell me is this safe and why would they do this?
my wife uses the car to take kids to school so i am a bit concerned.

p.s. tried to call garage but they were closed.
dweeb monkey is offline  
  5 Lastest Threads by dweeb monkey
Thread Forum Last Poster Replies Views Last Post
Megane - crunchy gears Engines Bob925 4 1127 14th March 2008 09:34 PM
strange electrics Electronics dweeb monkey 4 986 11th December 2007 09:37 PM
track rod end removal Steering and Suspension dweeb monkey 5 5481 24th November 2007 11:47 AM
cv boot change Wheels & tyres dweeb monkey 2 1265 20th November 2007 09:40 PM
Renault Megane - Hub Nut Question Brakes/Hubs Lagdti 3 1943 15th August 2007 06:58 PM
For the best viewing experience please update your browser to Google Chrome