Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II Phase 1 - Interiors - Instrument Panel Failure

View Single Post
post #11 of (permalink) Old 24th January 2006
Junior Member
Join Date: Oct 2005
Posts: 13
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Just an update to let you know how I got on. Contacted Renault UK about the problem, they said they wouldn't do anything until they had a report from my dealer. Took car to dealership and was charged 48 to be told the car needed a new pod. A new pod was 433 including fitting and VAT. Contacted Renault UK two weeks later to see if they had received the report in which they hadn't but they phoned me the next day to tell me that because of the age of the vehicle ( four years) they were not prepared to compensate so I had to have a new pod fitted. 433.00!

Was Watching the BBC's Watchdog programme tonight and they covered a known problem with the Audi TT's dash pod. Same symptoms. They dealt with the case to Audi UK because of the amount of people complaining to watchdog They are replacing the pods free of charge and compensating to previous customers.

I have sent an email tonight about mine and urge all you others with this problem to also write in It must be worth a try?

I have also had the problem of the air conditioning panel illumination flickering and found this thread very helpful and has solved my problem. These forums are excellent!
Currently in Shaun's garage:
Laguna II 1.8 Expression 2001
Shaun is offline  
For the best viewing experience please update your browser to Google Chrome