Renault Forums :: Independent Renault forum - View Single Post - Laguna 3 coupe 2.0 DCI ABS

View Single Post
post #1 of (permalink) Old 13th July 2015 Thread Starter
Junior Member
Join Date: Mar 2010
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Laguna 3 coupe 2.0 DCI ABS

Can't find any info on the matter. Abs light is on, ABS, ESP and Brake System faults showing on start up. After I changed the front discs and pads these faults appeared about 30 miles later. The old discs had to be hammered off. There is also a shudder from the steering wheel only when braking hard from 70ish mph.
I had the fault code read, it's showing front right abs sensor open circuit. I replaced the sensor, fault still there.
Is the abs ring in the hub on this model (2010)? Could I have damaged the hub and abs ring hammering off the old discs? Can the fault "abs sensor open circuit" mean that the ABS ECU has not received the correct signal from the sensor,(ie sensor is ok but abs ring is faulty) as the old sensor has same resistance as the new sensor. ( few K Ohms one way, open the other, diode check works across sensor contacts).
Booked into Renault in a few days time. If anyone has had experience of this fault please pass on any info, thinking of changing the hub myself depending on the feedback from the questions above.
Thanks in advance for any input.
Currently in gilmour182's garage:
2005 clio 182 cup
gilmour182 is offline  
  5 Lastest Threads by gilmour182
Thread Forum Last Poster Replies Views Last Post
Laguna 3 coupe 2.0 DCI ABS Brakes/Hubs TTT 25 2175 13th July 2015 10:16 PM
Premature Engine failure..Pls record just how... Engines notsofast 11 2388 23rd March 2010 04:19 PM
For the best viewing experience please update your browser to Google Chrome