Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - 2.0 IDE engine problems !

View Single Post
post #44 of (permalink) Old 1st October 2007
Junior Member
Join Date: Sep 2007
Posts: 21
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Duran View Post
Well i tried all the usual stuff Injector Cleaner and Super Unleaded. But still the same.

So i am in need of a new Fuel Sensor, which im told by Renault is the cause of my problem.

They want to charge me 150+ Vat and 40 + Vat labour.

Do any of you know where i can get my hands on a Fuel Sensor for a 52 Plate 2.0 IDE Laguna for less that 150 before i give Renault the go ahead.
Another thing, reading the thread here, changing the fuel sensor has not fixed the problem for other people. For Ashes told me what often happens is that you need to open the engien and clean it up and investigate, i.e. you may as well get a new engine. In other words, if it was just the fuel sensor, they'd ahve told me. Well, I woudl have hoped so. By the way, they recommended I just live with it. I will try the injector cleaner fluid and super unleaded as that seemse to have improved the situation. As long as I get to where I was a few months ago, i.e. noticable lumpy idle, but not shaking me and my car so much as to make my exhaust rattle, then I will ne happy.
Currently in FunkyMonkey's garage:
2002 Renault Laguna II 2.0iDE Initiale
FunkyMonkey is offline  
For the best viewing experience please update your browser to Google Chrome