Renault Forums :: Independent Renault forum - View Single Post - Faulty Vacuum pump - brakes and turbo

View Single Post
post #1 of (permalink) Old 20th August 2015 Thread Starter
Join Date: Aug 2015
Posts: 54
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 8
Thanked 1 Time in 1 Post
Faulty Vacuum pump - brakes and turbo

Espace 53 1.9 DCI

Ok my brakes work but not 100% It will slow me down but wont hard stop / jerk , it crawls to a stop, no matter how hard I press pedal. Sometimes it works better at times

Car in garage he wants to see me tomorrow face to face as he is not sure but thinks it could be a faulty vacuum pump?

Reading on here it could also affect my turbo (wastegate)? I am also experiencing poor acceleration in low gears it will take 10-15 seconds to get full power, but then sometimes it gives me all from start sometimes not.

Could both issues be from the vacuum pump or a leak in the vacuum?

Or a faulty turbo causing a vacuum leak
Currently in Henhead's garage:
53 Espace IV
Henhead is offline  
  5 Lastest Threads by Henhead
Thread Forum Last Poster Replies Views Last Post
Still major issues with brakes Brakes/Hubs Dancingdad 1 202 24th March 2016 04:20 PM
Better brakes after drying out ecu Brakes/Hubs Henhead 3 536 20th December 2015 06:41 PM
wet ecu - Faults Electronics Mike H025 11 748 17th December 2015 01:06 PM
Hard pedal, ESP Light after turbo change Brakes/Hubs mord 3 332 8th December 2015 05:04 PM
New turbo now ECU fault!!!!!! Electronics Meganeman 4 364 19th November 2015 04:31 PM
For the best viewing experience please update your browser to Google Chrome