Renault Forums :: Independent Renault forum - View Single Post - Megane III Brakes Problem

View Single Post
post #11 of (permalink) Old 16th September 2015
Platinum member
ours2012's Avatar
Join Date: Dec 2014
Posts: 10,533
Nominated 30 Times in 26 Posts
Nominated TOTW/F/M Award(s): 10
Thanks: 1,527
Thanked 1,601 Times in 1,292 Posts
Re: Megane III Brakes Problem

When you say the pedal goes down, does it drop under pressure,,try this test,,,get in the car dont start the engine,and pump the pedal until it goes hard,Hold your foot on the pedal,does it stay at the top and not drop ,if it drops under your foot pressure then check for leaks,,,i know you say your level is correct ,have you placed a light in the reservoir to check as some times its hard to see through the sides of the reservoir and it looks ok,,to check your servo,start the car with your foot on the pedal,you should feel it drop,this is the vacuum in side the servo ,does it now go down ,pump the pedal it should now go hard again ,stop pumping take your foot off ,press the brake again the servo should build the vacuum back up and your pedal goes down slightly,,,iF these tests pass ok then it would point to an issue with the abs unit (the part that carries the fluid )Inside are solenoids that hold the fluid and these are allowing the fluid to pass over them ,,,
Currently in ours2012's garage:
My Baby ( or the shed on wheels )Laguna 2 estate
ours2012 is offline  
For the best viewing experience please update your browser to Google Chrome