Renault Forums :: Independent Renault forum - View Single Post - New CD player killed my speedo

View Single Post
post #4 of (permalink) Old 20th October 2007 Thread Starter
Junior Member
Join Date: Oct 2007
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

It was a new LG replacing the renault CD player. I did consider a like for like - there was one on ebay but had to get something working very quickly for a series of long trips with my son.

So you're spot on there Horatio. I found this out when I went back to Halfords - a fifty mile round trip (in the wrong direction) just before having to drive back to Edinburgh. The guy who does the fitting there was able to sort the wiring and didn't charge me (he also removed the old CD unit the previous day, saving me the 4.39 for a pair of pins).
At least we had CDs to listen to on the long journey, and I was able to see my speed going past all those cameras on the northern stretch of the A1. I do miss looking at the display on top of the dash though.

I didn't exactly follow along with what the fitter did, but it did seem to be just disconnecting one wire from from the block - I'd hoped he would tellme this over the phone but alas...

Thanks for your replies. I'm surprised this quirk hasn't come up here before, but here we are helping the next person it happens to...

all the best.
Currently in Tangent's garage:
Laguna 1.8 Sport
Tangent is offline  
For the best viewing experience please update your browser to Google Chrome