Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Horn Not Working*FIXED*

View Single Post
post #1 of (permalink) Old 23rd October 2007 Thread Starter
Junior Member
Join Date: Oct 2007
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Clio - Horn Not Working*FIXED*

I am a new member, so excuse me if this is already posted somewherem, but i have searched everything to try find the answer and i cant.
I have a 1998 Renault Clio 1.6 RXE and i have couple questions that i hope someone might no the answer to!
firstly my horn doesnt work, it did when we first got it last year (mind you when it did work it was pretty poor) i dont think its the switch on the side of the steering wheel i think its actually the horn.
i have seen on various sites to check the wires etc....
I wouldnt even know where to start looking for my horn. i know its under the bonet but dont have a clue where, so thats my first question...WHERE IS MY HORN?
secondly when i eventually find it what am i looking for?
cables, box an actuall horn. some people say check the cables if there ok you need a new horn, how much are these? and can i fit it my self.
the second question is when i bought it my Dad said the cluth was very high, something about adjusting to its max without replacing it...anyway in the last couple months sometimes i am finding it dificult to change gear and sometimes i have to list my foot of the cluth and push it down again and its fine. do you think this could be related to this and if so will this be pulled up in a MOT. also if i have to fix it, do i need to change the whole cluth and how much will that cost?

i need to know ASAP as i have an MOT at the end of the month and wanna fix it before i go..

Please Help

Currently in Amiz's garage:
Renault Clio 5 dr 1.6 RXE

Last edited by Amiz; 23rd October 2007 at 01:27 PM. Reason: misses question off
Amiz is offline  
  5 Lastest Threads by Amiz
Thread Forum Last Poster Replies Views Last Post
Renault Clio - Horn Not Working*FIXED* Clio Amiz 6 29856 23rd October 2007 01:06 PM
For the best viewing experience please update your browser to Google Chrome