Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.8 16v Throttle Problem*FIXED*

View Single Post
post #14 of (permalink) Old 25th October 2007
Junior Member
trevstamf's Avatar
Join Date: Aug 2007
Posts: 5
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 8 Times in 2 Posts
Laguna 2 injecion fault probs, throttle body,Injec ecu

ok guys here goes this i my story , ive posted about this on forum a few times ,this problem has been driving me barmy for months , where the car throws up a fuel injection faut, runs rought at idle , no accelerator, and revs between 2000 to 5000 revs al same probs as u all report , wait a bit and it resets after varing time

i went to dealership to cut a long story short and at daft cost had throttle body striped n cleaned, wiring checked, new plugs then did it again , so had new throttle body wiring checked again told all was well, behold it did it again

so i went to an independant place had full wiring loom opened an checked found broken wire fixed that took off main ECU from under battery tray ( no good place to put it ) an guess what all plugs n pins on ECU corroded to the hilt
so they are currently in the process as i post trying to fix it

also all the fault codes it throws up are not really faults the ecu ges confused and reads signals wrong ive had them all
to list a few- flywheel sensor, pollution monitor ( but thats coz its not running efficiently) and a few more

Top n bottom is when the car drives its ok so, if all else fails its a new ECU quoted 334 for part then requires reprog to car so god knows and am poss thinking if they cannot fix the corroded plugs a new wiring loom


If anyone can add to this please feel free
trevstamf is offline  
For the best viewing experience please update your browser to Google Chrome