Renault Forums :: Independent Renault forum - View Single Post - sorry to bring up TDC sensor again!

View Single Post
post #6 of (permalink) Old 29th October 2007
Diamond member
OzRX4's Avatar
Join Date: Mar 2006
Posts: 465
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 15
Thanked 31 Times in 31 Posts
Originally Posted by gazdagod View Post
thanks soooo much i think i know where it is now but what you clean it with?

ive seen other posts saying wd40, others say wd40 is bad for it so what would you recommend?

and finally what part do you clean all of it?
Have you cleaned it yet?
I'd use a little carbie/ throttle body spray cleaner to remove the deposits on it, spray some onto a rag and wipe it over. Don't use WD40 as it's only really a water dispersant/short term lube spray and will dry and leave a residue which will make it dirty up faster this time.
Try a little metholated spirit or kerosene if you haven't anything else, just make sure you wipe it dry carefully and don't leave any visible residue and you should be fine.
ALso, while you are there, unplug and replug the connection a few times to clean the points in it.
The area to clean is the outer most 'point' opposite the wire end, which would be up very close to the flywheel pick-up as it spins by.
Currently in OzRX4's garage:
2001 Megane Scenic RX4 Privelege Verve, 2003 Clio Privelege 1.4auto, {son's car}

Last edited by OzRX4; 29th October 2007 at 11:22 PM.
OzRX4 is offline  
For the best viewing experience please update your browser to Google Chrome