Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Speedo And ABS Fault

View Single Post
post #4 of (permalink) Old 30th October 2007
Still a Petrolhead but also like diesel
Truckbusuk's Avatar
Join Date: Apr 2006
Posts: 2,311
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 0
Thanked 17 Times in 17 Posts
Hi kolin, the speedo on the Clio2 is an electronic sensor mounted on the gearbox at the flywheel bellhousing between under the inlet manifolds, at the RHS back of the engine between the engine and the firewall ... so I doubt that is having a direct impact on your ABS problems.

Do a search on Clio2 speedo ... plenty on info and on how to change it ... I'd check the connector for corrosion first as it may only need a clean ...

Like lagdti says the road speed and wheel rotation is monitored by the ABS computer using a speed sensor at the wheel, I'm not sure if its on the hub or a ring on the driveshaft, again there is plenty of info on the forums.

The speedo sensor is a 10min job and the part costs about 27 from Renault, I'm not sure about the ABS parts.

Out of interest what are you doing to "test" the ABS system?

It could also be because its Green ....

Hope it helps

Why is it the older I get .... the better I think I was ?
Currently in Truckbusuk's garage:
Clio2 1.4RT Phase1(VF1BB0S) + Volvo XC90 SE Lux D5 Geartronic

Last edited by Truckbusuk; 30th October 2007 at 02:01 PM.
Truckbusuk is offline  
For the best viewing experience please update your browser to Google Chrome