Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Speedo And ABS Fault

View Single Post
post #8 of (permalink) Old 30th October 2007
Still a Petrolhead but also like diesel
Truckbusuk's Avatar
Join Date: Apr 2006
Posts: 2,311
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 0
Thanked 17 Times in 17 Posts
Originally Posted by kolin View Post
oh it does come on on 'system startup' then goes off. at this point when the abs light is NOT on, the brakes dont work properly, when the abs light COMES ON, then the abs works...

i know that when the abs light is off, the abs isn't working. very very strange. the juddering and clicking what i'm experiencing when i try to brake...
Hi kolin ... I'm really confused now ....

The ABS light should NEVER come on when your using the car even when braking in an emergency (realistically the only time the ABS should activate if the wheel looses grip and is about to lock) ... if it does there is a fault in the system.

The ABS system should not operate in normal braking.

If you have managed to activate the system then the pedal pulse/judder is totally normal ABS operation and is not a fault ... I admit it does feel a strange sensation but the ABS if activated and as long as you keep your foot hard on the pedal will stop you without locking-up and in a shorter distance than you could yourself when braking normally.

I stress the ABS should never edit - "kick-in" in normal driving circumstances ... if it does you have a fault and you should get checked professionally.

Are you maybe confused at how your ABS system operates, and what you should be experiencing ?

Why is it the older I get .... the better I think I was ?
Currently in Truckbusuk's garage:
Clio2 1.4RT Phase1(VF1BB0S) + Volvo XC90 SE Lux D5 Geartronic

Last edited by Truckbusuk; 30th October 2007 at 03:04 PM.
Truckbusuk is offline  
For the best viewing experience please update your browser to Google Chrome