Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.8 16v Throttle Problem*FIXED*

View Single Post
post #19 of (permalink) Old 2nd November 2007
Junior Member
Join Date: Jul 2007
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Many many thanks to trevstamf to share your vary valuable experience. I owned this Laguna II 1.6 16V Expression 2002since 4 month ago, recently had exactly the same problem. My car is runing on LPG but this problem can come whether it is on petrol or LPG. It used to happen once a week, after driving for a while, stop to do some shopping, when come back, the "electrical fault" light went on and run into limp mode. From time to time it also happens during driving after a short break. Last week it started happening everyday. Sometimes a restart will solve the problem sometimes not.

After searching in the forum I also suspected the throttle body can be faulty. Last month after a long trip to France I had the car fully serviced and new igination coils , new sparks fitted. The guy in the garage told me the throttle body is working fine.

As an electronics engineer, my instinct told me it could most be a contacting problem somewhere. But I do not have any clue where to start with. Thanks to trevstamf's post. The day before yesterday I open my car for the first time by myself. I removed the battery, the sensor box and cleaned everything, reconnected doggy wires (I have many extra wire and some extra boxes for the LPG part). But I have not touched the ECU part. As far as I can see, the ECU is sealed in an metal box. It is covered by a piece of metal that I can not remove. I am thinking to buy a Haynes manual before proceed. I will try to make some pictures next time.

My Laguna was running quite ok for the last two day, but it is a bit too early to be happy.
Currently in mzhao's garage:
2002 Laguna II 1.6 Expression LPG

Last edited by mzhao; 2nd November 2007 at 12:25 PM.
mzhao is offline  
For the best viewing experience please update your browser to Google Chrome