Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #321 of (permalink) Old 4th November 2015
Junior Member
Join Date: Nov 2015
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Originally Posted by MrSomebody View Post
Its funny, that a topic about the problem I have sits on the first page. Im new here, but l'll get straight to the point. I just bought my 2003 clio couple days ago and already im having problems with it.
Of course I have the same problem as everybody else- car stutters, kinda misfires, the toxic fume light blinks and no power. However, here starts the other side of my clios story.
Two days ago it started misfiring, lost power and the first thought I had- faulty spark plug, or spark lead.
I checked the forums high and low , got educated on all the coil symptoms and went to a local garage. After changing the spark plugs(NGK), and fitting brand new coil pack, the problem didnt go away. Mechanic tried reading the faults- turned up nothing. Why Im here posting my sad story? Because this problem occurs when it wants. I drove all day yesterday without any problems, blinking lights or loss of power. Im pretty good with cars (had 2005clio couple years back), but I never stumbled upon a problem, that are so common, but couldnt be fixed with common repair.
What my thoughts are- Clean the throttle body , check/clean TDC , change the coolant sensor and lastly go for the injectors (whole rail+4 inj for 25pounds from e-bay sounds affordable).
What I cant get my head around- why this problem isnt always there. I've had jap cars before this clio(mazda,nissan,subaru) so I've narrowed down anything that might affect fuel mixture/exaust readings and upset the ECU . As far as I know, this Clio just recently passed its MOT and had a new MAF fitted. Im not afraid of getting my hands dirty,but I would really appreciate if someone could point me into the right direction. Such a small car, but such a huge problem with this .
Mr Somebody, sorry to bother but you seem like you know more about the car and i thought it would be best to ask you.

I have pretty much the same thing as yourself, loss of acceleration, limp mode, stuttering between gear changes.. but unfortunately for me i have no lights coming on. And exactly like you car.. it only plays up when IT wants too. i can drive the car for a week or 2, or maybe even a few days. then it wants to play up. mostly mornings, but i have had trouble in the evenings too.

Without lights warning me, what could be the 1st route i should take? Im still paying for the car on a finance for the next year so i cant abandon it yet (although i will as soon as i can) but obviously i cant afford to pay too much as its still costing me to run.

thanks if you can advise any route. im a young female & i know many mechanics will see pound signs just looking at me.

p.s it passed its mot in september! shocking i know.

thank you.
Currently in nickinoo's garage:
2007 Renault Clio 1.2 Sport.
nickinoo is offline  
For the best viewing experience please update your browser to Google Chrome