Renault Forums :: Independent Renault forum - View Single Post - Hard pedal, ESP Light after turbo change

View Single Post
post #2 of (permalink) Old 12th December 2015
Diamond member
Join Date: Dec 2015
Posts: 147
Nominated 1 Time in 1 Post
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 27 Times in 22 Posts
Re: Hard pedal, ESP Light after turbo change

Originally Posted by Henhead View Post
Espace 1.9 dCi 53 plate

I had my turbo changed as it was leaking oil externally. The only other issue I had with car prior was the service and handbrake light. electronic Hand brake seemed to work fine tho.

I bought a new turbo cartridge but the turbo housing was damaged as well so I got a 2nd hand faulty turbo for the housing, my local garage changed it for me.

When I got it back the esp light and the heart beat light (not sure what its called/for) came on not long after. it then went into limp mode and would not drive faster than 12mph in 1st and a speedy 32mph in 6th.

When it was getting driven onto the tow truck the guy said it felt like it had no brakes and would not hold on the incline so had to drag it up instead.

Went to garage who cleared the ESP issue including parking brake and service light but it came back next day when he went to check it. cleared it again drove it home, but brake issue was still there.

car would brake but did not have stopping power, car travelled a lot with brakes fully down as if it had no bite.

Went to take it to garage this morning after being sat for 2 days and boom esp light back on and limp mode. parking brake would not automatically disengage, disengaged when I used switch. Drove the 3 miles to the garage in limp mode.

Any ideas of what issue could be? Could an issue with the turbo cause the esp light.

I know the brakes could be due to a vacuum leak from the replaced turbo but could that cause the ESP / Limp issue?
sounds to me like who ever fixed the turbo may of knocked wiring harness somewhere i would check wiring for a start. as for brakes being hard, sounds to me then pressure pipe or the pressure vacum pump needs looking at. once again changing turbo has knocked of broken the hard fee pipe somewhere maybe. like all jobs on these cars you need a proper diagnostics scan otherwise you just end up replacing parts that dont need replacing
Currently in mike1967's garage:
buy repair renaults
mike1967 is offline  
For the best viewing experience please update your browser to Google Chrome