Renault Forums :: Independent Renault forum - View Single Post - central locking/immobiliser problems on 1998 scenic

View Single Post
post #11 of (permalink) Old 10th December 2007
Junior Member
Join Date: Feb 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by blueboy View Post
hi guys and gals, i've just joined the forum as i have recently bought a 1998 megane scenic rt 1.6e and have some problems with the electrics. The previous owner did tell me the car had some electrical problems due to a water leak so no complaints there.

When i bought the car i had to tow it home since the battery was flat and i coudnt get it to jump start. I removed and charged the battery and the car started first time and i have to say it ran like a dream and was a total joy to drive. The problem according to the previous owner was causedby a water leak causing the electrics to malfunction. I noticed that when i got the car going the drivers door, o/s door and tailgate and the petrol flap locking pin did not work and for the last week i've had to climb over the passenger seat to get in as the drivers door wont even open using the key. I found that the water leak seems to be coming from either the roof aerial or the sunroof or top of the windcreen as it was dripping from the panel that houses the remote locking sensor. I assumed this was what stopped the central locking from operating properly as water had contaminated the sensor. I havent had time what with xmas to locate where the water was coming in and as the car was driving fab i just put up with having to enter via the passengers door for the time being. The problem got worse on new years eve, while driving, the central locking started switching itself on and off constantly, and when i stopped for petrol i couldnt get the car to start at all. the central locking keeps operating even when the key is removed from the ignition. Im assuming the circuits have been soaked (its been pouring down in glasgow for the past couple of days) The bottom line is that the car will no longer start although it is turning over fine. I know there is an immobiliser that means i have to start the engine withing 30 seconds of opening the door so i guess the sensor in the roof has been 'shorted' with the water leak. there are a few other things not working but they are minor, ie, clock, heater rear screen but maybe they work through the same relay, i dont know. If any one can help with some advice id greatly appreciate it.

Do i have major problems caused by the water leak affecting the locking which in turn is affecting the immobiliser, or is it just a case of changing a 'blown' relay?..

sorry for such a long winded post but hope it explains the problem fully. Ned help guys as im stuck without the car and due to start work again tomorrow..cheers
If it's a sunroof problem then either fix the leak,let me know how,or tape around it to stop the leak like I did,it gives the electrics time to dry out,but my ir key fob doesn't work and I have to use the security code,10 from renault dealer.
Currently in stanleyella's garage:
1998 renaul megane 1.9 dti
stanleyella is offline  
For the best viewing experience please update your browser to Google Chrome