Renault Forums :: Independent Renault forum - View Single Post - Renault Megane 1 - Erratic Tacho/Engine Cutting Out*FIXED*

View Single Post
post #26 of (permalink) Old 11th December 2007 Thread Starter
Junior Member
Join Date: Dec 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Getting dispondent

Hi everyone

Just like to say thanks to all the advice I have had so far.

Might as well start from the beginning.

My Megane MK 1 1.6 K7M (engine) has an intermitant fault. Rev counter sometimes becomes erratic (no change in engine tone) after this happens the car will loose power ie kangaroos. Also engine will die when slowing down, rounderbouts, junctions etc. Fault appears to be worse when engine cold.

Now I will explain what I have done I have checked all vacuum pipes and replaced the MAP sensor to inlet manifold pipe. Have checked oil (no contamiation as far as i can see).
Checked all electrical connections and buzzed out all earths.
Put in several doses of injector cleaner.

Today I decided to change the TDC sensor, I thought I had cured the problem, but it started again. The fault seems to have calmed down a little, does anyone know if the TDC sensor plug suffers from high resitance crimps. I have been told that Renault now supply a new plug & wiring loom with the new TDC sensor.

I am convinced this a electrical problem as the erratic rev counter must be giving me a clue.

Look forward to any advice

Regards Marty
Currently in marty49's garage:
Megane 1 1600 Alize also rides a Giant GTE mountain bike
marty49 is offline  
For the best viewing experience please update your browser to Google Chrome