Renault Forums :: Independent Renault forum - View Single Post - Sat Nav problem

Thread: Sat Nav problem
View Single Post
post #5 of (permalink) Old 21st December 2007
Diamond member
len_0onx's Avatar
Join Date: May 2007
Posts: 249
Nominated 1 Time in 1 Post
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 5 Times in 5 Posts
Originally Posted by sheppd91 View Post
Hi. Yes, it still works perfectly when all the noise stops. I can't get it to do it when the unit is removed and accessible, so I haven't got a clue what it is. Its sounds like a kind of 'whirring' noise accompanied by a 'clicking' noise as if there's a tooth missing off a gear wheel and the unit is retrying some operation.

A CD reader will normally attempt to focus on the CD first. If this is possible it then spins the disc to see if it can retrieve data. As far as I can tell, its not spinning at this stage which would tally with the laser being dirty or weak. Over Christmas I may take the unit out and clean the laser by hand. Laser lens cleaning discs can be quite useless sometimes.

May I ask if you smoke in the car? I've come across CD issues related to people smoking in the car which can create deposits on the laser lens - although I don't smoke. Also, using a CDROM rather than an original CD may have some bearing on the problem, but I have tried both and it seemed to make no difference.
Using a CDROM copy can cause these issues. Try making a new copy with a high quality CD Sony, TDK or similar. This solved a similar problem for me.
Currently in len_0onx's garage:
Megane Sports Tourer
len_0onx is offline  
For the best viewing experience please update your browser to Google Chrome