Renault Forums :: Independent Renault forum - View Single Post - Megane Mk2 ABS issue 2003 1.6 16v petrol

View Single Post
post #1 of (permalink) Old 31st January 2016 Thread Starter
Junior Member
Join Date: Jan 2014
Posts: 20
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 16
Thanked 3 Times in 2 Posts
Megane Mk2 ABS issue 2003 1.6 16v petrol

Hi All,

Me again with my problem Megane!!

Ok so I have been having a problem with the ABS, Stop and handbrake light coming on while driving and staying on. They all ping on at the same time. Sometimes they will come on straight after starting the car sometimes they come on after a few miles of driving the car. The brakes sometimes make a grinding noise when braking hard... this sounds like it is from one caliper only. The MOT has failed due to this as they pinged on during the mot which is a pain I have checked the fluid level and all seems fine. I have checked the fuse and it is fine. I did change the rear discs for some non genuine Renault ones and it appears from what I remember this issue has been there since changing them. The car stops as it should when braking it is just a pain in the rear....literally

All help and advice appreciated as always
Dave1978 is offline  
  5 Lastest Threads by Dave1978
Thread Forum Last Poster Replies Views Last Post
Megane Mk2 ABS issue 2003 1.6 16v petrol Brakes/Hubs batfink5 12 727 31st January 2016 03:57 PM
Renault megane 1.6 petrol 2003 slave cylinder... Transmissions Dave1978 5 785 17th September 2015 07:20 PM
Megane mk2 knocking noise Cars & motoring mahermj 15 3517 2nd February 2014 06:02 PM
Megane mk2 subframe removal Steering and Suspension klopperg 7 3329 25th January 2014 02:08 PM
For the best viewing experience please update your browser to Google Chrome