Renault Forums :: Independent Renault forum - View Single Post - 1.4RT Auto 1994 - Indicators not working?

View Single Post
post #1 of (permalink) Old 26th December 2007 Thread Starter
Junior Member
Join Date: Jul 2007
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
1.4RT Auto 1994 - Indicators not working?

Driving home tonight I noticed that the indicator lights were not coming on the dashboard.

Further inspection highlighted that when using the stalk to indicate left or right, no bulbs lit. Tried the Hazard switch and all bulbs lit and flashed as normal though.

Too dark at mo to check anything, and have read on here about a relay issue. But not sure where to start looking.

So some questions (don't have a manual)

Should I check the fuse box, if so where is it located?
Should I check relays, if so where are they located and which one do I check?
If relay issue, what is the typical cost of one of these?
Is replacing a relay an easy and inexpensive job for a amateur to do?
Are they any online images of what the fuses in the box relate to, and likewise for the relays, which is which?

Also is it illegal to drive without indicators working, as don't want to receive a pull and end up with points / fine, especially at this time of year.

Many thanks.

Last edited by oasisfever; 26th December 2007 at 12:14 AM.
oasisfever is offline  
  5 Lastest Threads by oasisfever
Thread Forum Last Poster Replies Views Last Post
1.4RT Auto 1994 - Indicators not working? Electronics oasisfever 1 679 26th December 2007 12:13 AM
For the best viewing experience please update your browser to Google Chrome