Renault Forums :: Independent Renault forum - View Single Post - Come on, Whats the WORST car you have ever OWNED!?

View Single Post
post #41 of (permalink) Old 4th January 2008
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
My dad had a Rapier too (don't ask me what year.) I can only vaguely remember it, but I do recall he was made up because it had overdrive

Of cars I've had from new, Vauxhall was by far the worst ownership experience. The car itself wasn't that bad, but the dealers just didn't give a about looking after it. It had numerous niggly faults that the dealers just seemed indifferent about - ECU warning light coming on at random, the temperature gauge soaring out of the top of the red even though the engine wasn't overheating. The back wiper not working reliably (I eventually diagnosed and repaired that myself - poor boot lid alignment meant that the contacts weren't making properly.) It even took two visits to get them to replace a gas strut on the boot (I only wanted the part - I was happy to do it myself.)

Their crowning achievement (yes, I know I've done this one to death) was to let the timing belt go to 63K miles when Vauxhall had reduced the recommended interval to 36K. Not only that, they tried to blame me for the failure because apparently it was up to me to request that it was done at 36K.

Fortunately, it didn't bend any valves when it failed.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
For the best viewing experience please update your browser to Google Chrome