Renault Forums :: Independent Renault forum - View Single Post - sat nav display problems

View Single Post
post #8 of (permalink) Old 10th January 2008
Platinum member
bpowell555's Avatar
Join Date: Apr 2007
Posts: 2,861
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 20 Times in 18 Posts
Originally Posted by Horatio View Post
First off, have you checked the 20 amp fuse behind the ashtray? If this is blown, then the stereo won't work and the sat-nav screen will be dead. If that's okay, then try leaving the battery negative lead disconnected for a few hours (preferably overnight.) If that still doesn't sort it, then check every other fuse even if it seems to be unrelated. There's a fuse box in the end of the dash, and another one under the bonnet. There's even one hidden inside the glovebox on some models (you have to remove the lining) which, while I don't think relates to the sat-nav, might still be worth checking before giving up hope.
Please god please please please let this be what's happened to mine... garage replacing the gearbox found the battery dead and jumped it... never even noticed the screen was dead. I really don't want to take this to small claims...

Having said that, 1100 for a box and clutch aint bad
Currently in bpowell555's garage:
2002 Renault Laguna II 2.2dCi Initiale, 1990 E30 325i Touring (Bavarian Tigzwerken Express)

Last edited by bpowell555; 10th January 2008 at 08:19 PM.
bpowell555 is offline  
For the best viewing experience please update your browser to Google Chrome