Renault Forums :: Independent Renault forum - View Single Post - What's the stupidest addition you've made to your car?

View Single Post
post #43 of (permalink) Old 12th January 2008
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
Originally Posted by lagdti View Post
My second ever car was a rusty old Mk1 Fiesta,but it happened to be a rusty old 1.3 Ghia(Ooooooo.....Ghia!:rofl) with a twin choke Weber carb.It used to go like ~~~~,well it seemed to back then!.I decided to fit a pair of (very second hand) air horns to it to give it that rally car sound().Unfortunately the compressor that ran the horns was louder than the horns themselves and it took it's time in gathering enough puff to make a farting noise from them.
Do air horns count? We'll be including air fresheners and digital clocks next.

I stuck a set of twin Fiammas on the Escort because the original horn was so feeble. They were great, until one time I really needed the horn (to scare the crap out of some idiot taxi driver who desperately deserved it) and they did nothing. It turned out that the pipe had popped off the compressor. An easy fix, and they were fine after that.

I stuck a triple set of Fiamas on the Astra, as that too had a thoroughly feeble horn as standard. I was always worried that if I beeped it once too often, Wile-E-Coyote might appear out of nowhere and start chasing me down the road.

The Mazda and the Lagunas, to their credit, seemed to have half decent horns to start out with. I'd put it down to having grown up, but I only turned into an old fart when I got the first Lag

Going back to wastes of time, I should probably go into more detail on the aforementioned Moss car alarm (see a few posts back) that I had fitted to the Escrote. I bought it thinking it was well within my DIY capabilities, but on reading the instructions on where you were allowed to put it (avoiding proximity to certain engine and electrical components) I couldn't find anywhere to stick it. Eventually, I paid Halfords to fit it, and they stuck it the first place I thought, that contravened the guidelines in the instructions.

They'd hooked the immobiliser up to the starter circuit, which I don't think it was designed to cope with. Being used to driving an automatic (the Audi) I used to turn the engine off in the IMO car wash. That was where Harry Moss let me down the first time: The car wouldn't re-start and I ended up clogging up the whole conveyer belt system We finally got it started, and I went back to Halfords where they bypassed the immobiliser free of charge.

I had the optional ultrasonics with the cool Knight Rider scanning LED display. These were worse than useless - the little adjusting dial effectively gave you two settings: The first wouldn't go off if you sat in front of the sensor and thumped it with your finger. The second would go off if a peekingese farted at 200 paces.

What a heap of crap that was. I forget what I paid for it, but I'm sure it was more than I could afford at the time.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
For the best viewing experience please update your browser to Google Chrome