Renault Forums :: Independent Renault forum - View Single Post - Throttle position sensor????

View Single Post
post #1 of (permalink) Old 14th January 2008 Thread Starter
Diamond member
Join Date: Jun 2007
Posts: 135
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Throttle position sensor????

03/53 Lag II 1.9 dci 157k miles, average fuel consumption 36mpg, is it possible that the Throttle position sensor (TPS) could be worn out, tried backing off the throttle a bit whilst cruising the other day, and the trip computer showed the avg consumption rise from 35.2 to 38.7 over ten miles, so was just wondering if there is a way to set, or test the tps to see if it is working as it should, I know when its faulty the injection warning comes up on the dash, but I haven't had that, still trying to get to the bottom of why the fuel usage is so high on this car, its had a new MAF , the egr has been removed and cleaned, and all the crud removed from the inlet manifold, intercooler has been cleaned out, anyone have any ideas or thoughts?
Currently in 137MPH's garage:
2011 Laguna III 2.0 dci FAP Dynamique +
137MPH is offline  
  5 Lastest Threads by 137MPH
Thread Forum Last Poster Replies Views Last Post
Intercooler Pipework Engines 137MPH 8 2015 10th February 2008 07:11 PM
Throttle position sensor???? Electronics madnoel10 8 2998 14th January 2008 12:19 PM
Creaky Laguna 2 Engines madnoel10 11 2005 19th December 2007 10:20 PM
Sat Nav Wiring Electronics len_0onx 14 2738 23rd November 2007 01:09 AM
For the best viewing experience please update your browser to Google Chrome