Renault Forums :: Independent Renault forum - View Single Post - wiper blade problems

View Single Post
post #1 of (permalink) Old 16th January 2008 Thread Starter
Junior Member
Join Date: Nov 2007
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
wiper blade problems

Hi. I have a 2004 Scenic II. Been having problems with the wiper blades dragging and juddering accross the screen. Replaced the blades with new Valeo ones, cleaned the windscreen, but occasionally they still judder.

I have removed the arms and reseated them and tightened all the linkage nuts. I have tried bending the arms in and out, but nothing seems to cure it sufficently.

Anyone had similar problems or have any ideas on where to go next. I think there maybe something in bending the arms slightly, but not sure how far out or in to do it, as what i have tried so far hasnt worked.

bradspaul is offline  
  5 Lastest Threads by bradspaul
Thread Forum Last Poster Replies Views Last Post
Scenic II / Grand Scenic rear doors Bodywork hmsggg 3 1544 28th July 2010 09:41 AM
Rear caliper wind back tool - Help Tools & equipment jas_singh 4 4788 21st May 2008 08:02 AM
wiper blade problems Cars & motoring mrtotty 8 3361 16th January 2008 10:31 AM
trip range resets ? Why Electronics Horatio 1 843 18th December 2007 07:27 AM
SCENIC II - Drivers seat squeak Interiors bradspaul 4 1202 26th November 2007 10:10 AM
For the best viewing experience please update your browser to Google Chrome